Output sinlge layer in resolume 6

Home Forums Spout Support Output sinlge layer in resolume 6

This topic contains 11 replies, has 3 voices, and was last updated by  leadedge 1 week ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #4034

    GerarCasal
    Participant

    Hello, it is possible in resolume 6 output a single layer via spout? not entire composition.

    #4035

    leadedge
    Keymaster

    I am not sure whether this will meet your requirement but I have uploaded FreeFrameGL plugins revised for FreeframeGL Version 1.6 to GitHub (https://github.com/leadedge/Spout2/tree/master/FFGL).

    Both 32bit and 64bit versions are included. These are effect (SpoutSender) and source (SpoutReceiver) plugins and work on an individual cell in Resolume.

    #4036

    GerarCasal
    Participant

    Thanks so much! after a simple test works perfectly.

    #4037

    leadedge
    Keymaster

    OK that’s good. I was hoping to retire the Freeframe plugins but it looks like I should keep them up to date.

    #4038

    GerarCasal
    Participant

    I have only an issue, when I fade out a video source nothing happen in the receiver, then the video still at 0% (total fade out) this is an alpha issue? I been reading something in the forum but I don’t understand completely.

    #4039

    leadedge
    Keymaster

    Yes it’s an alpha issue. Are fading out using the opacity of the video, or the opacity of the SpoutSender plugin? I find no effect but the receiver does not go black. I will have a brief look.

    #4040

    leadedge
    Keymaster

    Try this one and let me know what happens.

    #4041

    GerarCasal
    Participant

    Now I can’t see anything, black screen on the receiver.

    #4042

    leadedge
    Keymaster

    This is a test version and does not work for memory share mode.

    Close Arena and open “SpoutSettings”. Do you see “Memory” selected? Select “Texture”, click OK and try Arena again.

    If you still see a black screen, open SpoutSettings again. Do you see “Memory” set once more? If so, there could be a graphics compatibility problem. Set to “CPU” and try again. It should work this time.

    Then in the Spout demo receiver select Help > Diagnostics. Click “Copy” and paste the results here so we can investigate further. Is this a laptop with Optimus graphics?

    #4067

    ravensc
    Participant

    You can do this in the Advanced output in Resolume.
    Create a new Screen, set it’s output device to spout
    https://resolume.com/support/en/syphonspout#advanced-output,
    and set the slice’s input in the screen to the layer you’d like to output:
    https://resolume.com/support/en/slice-routing

    #4043

    GerarCasal
    Participant

    Problem solved. works ok thru texture, memory or cpu delivers a blank screen.
    That thing with the alpha works ok now, i don’t see weird effects when using transparencies.
    Anyway I recorded a video, just to show U how the master’s fade out of the layers works, or what happens when U stop a video. I’m aware maybe it just the way it works, but U never know…

    (Admin edit – youtube link rejected)

    Sorry for the watermark, I download the recorder just for this.

    #4075

    leadedge
    Keymaster

    Sorry for the forum trouble. Still working on it.

    Anyway please try the method that Ravensc has outlined. The plugins might not do the job as well as this method.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.