Spout for Blender

Home Forums Spout Announcements Spout for Blender

This topic contains 14 replies, has 6 voices, and was last updated by  maybites 8 hours, 44 minutes ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #4247

    leadedge
    Keymaster

    Spout for Blender

    Martin Froelich, co-author of the Spout Processing library, has just finished a Spout plugin for Blender, the open source 3D creation suite. It makes use of the Spout for Python library developed by Ryan Walker. A collaboration of open source projects which is inspiring to see.

    #4249

    toastbrot
    Participant

    wow cool.
    danke martin und gruess.ivo

    #4250

    lisandroperalta
    Participant

    Hey guys! This is awesome, I waited for this for sooo long.
    I’ve tried to install it but I gives me an error , you can see it here
    I’ve followed all the instructions, What am I missing?
    Thanks in advance!

    https://www.dropbox.com/s/64tjglppo7ofnyp/Captura%20de%20pantalla%202019-03-14%2018.45.50.png?dl=0

    #4251

    maybites
    Participant

    @lisandroperalta:

    which blender do you have? I have tested it on three different machines and didn’t have any issues

    can you remove these lines at the beginning of the __init__.py script?:

    from rna_prop_ui import PropertyPanel
    from bl_operators.presets import PresetMenu

    I think they are leftovers from my copy and paste efforts..

    #4252

    lisandroperalta
    Participant

    hey @maybites

    thanks for the answer

    I’ve tried on an few weeks old blender 2.8 and a 2019-03-14 compile with no luck

    I’ve commented the lines you said and got another new error

    https://www.dropbox.com/s/i9dj2avcb1odpmr/Captura%20de%20pantalla%202019-03-20%2018.50.41.png?dl=0

    line 33 refers to spoutsdk

    I have Windows 10 64bits Single Languaje , Spanish.

    #4257

    maybites
    Participant

    do you have a 64 bit blender installed?
    is the SpoutSDK.pyd file inside a modules folder?

    #4258

    sunshine
    Participant

    Hello maybites

    I get exactly the same error message, lisandroperalta posted first.

    blender 2.80 latest build 2019-03-21
    Windows 10 64bit

    #4259

    maybites
    Participant

    I updated the addon and removed the unnecessary lines. I tried to reproduce your issues, but I was unable to.

    all I can say: stick to the instructions and cross your fingers..

    #4260

    lisandroperalta
    Participant

    Hey @maybites! I’ve downloaded your new code and it didnt worked, BUT, Ive downloaded again the Python SpoutSDK file and it worked!
    Looks so good!
    Any chance that suports eevee in the future?

    Maybe, @sunshie , you should try downloading everythin again? (Maybe a corrupted download?)

    Thanks again mate for everything!

    #4261

    sunshine
    Participant

    It runs like a charm!
    great job

    Thanks

    #4262

    maybites
    Participant

    yeah, hopefully it will work with EEVEE. There is that bug
    with nvidia cards. it actually works on my bootcamp on a macbook pro with an amd gfx card…

    if you know a developer at the blender institute to plead our plight..

    #4311

    nyom
    Participant

    First up! WOW!

    I’m pretty new to that VJ topic thing but a blender user since years and this tool is just epic, thank you so much.

    The installation went for me quite epic… no python style errors everything is fine. I just got one Problem. The Spout-Receiver finds the source of the blender image, but the video input just stays black.
    I tried evee/workbench-render, setting up more lights to enlight my scene, change the overall background from black to whatever, tryed nearly every spout settingconfiguration (dx9, internalgraka, share memory cpu or whatever)….
    Spout itslef always worked, so the sender programm was always correctly received by the receiverprogramm.

    I got a geforce mx150 and the newest version of blender.

    On the picture that i attach i’m in workbench renderer but yeah as you see there is nothing.
    https://ibb.co/MV1bXdf

    Maybe i missed something so simple… Any help is appreciated šŸ™‚

    #4312

    maybites
    Participant

    which blender version do you have? there is an issue with the latest beta: (https://github.com/maybites/blender.script.spout/issues/3)

    #4313

    nyom
    Participant

    Hey maybites,

    yeah i got the newest version so the one from the 24.05.2019. And i tryed an older version and yeah there it works but just in workbench renderer not in evee. Is this related to the nvidia gfx thingy?

    Thank you very much.
    Maybe you got a version from may 15th or so? Couldn’t find any former blender 2.8 beta release on the net. šŸ™

    #4314

    maybites
    Participant

    And i tryed an older version and yeah there it works but just in workbench renderer not in evee. Is this related to the nvidia gfx thingy?

    this is a bug, but at least I got the promise from the eevee developer to have it fixed until release (it is bumped up to highest priority now)

    but blender is still beta and they must have additionally made some API changes. so the plugin is broken for the time being if you use it with a blender 2.80 fresher than 2019-05-12.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.