Winamp Milkdrop plugin with Spout output

Home Forums Spout Announcements Winamp Milkdrop plugin with Spout output

This topic contains 80 replies, has 8 voices, and was last updated by  leadedge 4 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 81 total)
  • Author
    Posts
  • #957

    leadedge
    Keymaster

    Winamp Milkdrop plugin with Spout output

    Are you a fan of Winamp visualisations?

    The Milkdrop visualization plugin is open source and has been rebuilt for Spout output.

    Importantly this uses a different texture format than usual and should be used with the Spout programs and plugins from the latest Version 2.003 beta here :

    https://github.com/leadedge/Spout2/releases

    After installation you will find the files you need.

    1) Copy vis_milk2.dll to the Winamp plugins folder

    Run WinAmp and activate Visualizations.

    When the visualizer starts, Spout output is automatically started. You can use Ctrl-Z if you want to stop it and re-start it for any reason, such as saving computer resources when you don’t want Spout output.

    This seems to work quite well and with good performance, but give us your feedback on how it works or does not work on your system.

    Edit 26.07.15 – corrected links

    • This topic was modified 3 years, 8 months ago by  leadedge. Reason: Changed download instructions
    #970

    coolwithpie
    Participant

    It doesn’t let me select milkdrop as a visualization plugin on winamp after I replace it.
    Latest winamp, windows 7

    #971

    leadedge
    Keymaster

    This is probably because glut32.dll is missing. Put it in System32 or SysWOW64. I have also found it works in the Windows folder. You can also try putting it with VisMilk2.dll, or wherever Winamp.exe is located. Somebody else had the same problem and this fixed it. Let me know how you go.

    #975

    wildcat
    Participant

    I have had the same problem with getting this to run. When I copied the VisMilk2.dll file I noticed that the version that I downloaded from this site was smaller than the one built into Winamp. Can you please confirm which version of Winamp you have made this for as it could be that the latest version of Winamp is incompatible with this vesion of the Milkdrop plugin.

    #976

    leadedge
    Keymaster

    I think I figured out what is going on here – the file download is not working.

    Go to here :

    https://github.com/leadedge/Spout2/releases

    and download :

    Spout2_v2.001_files.zip

    Unzip to a convenient location. In there you will find the MILKDROP folder with the files you need.

    vis_milk2.dll should be 828kb
    glut32.dll should be 232kb

    Milkdrop isn’t part of the Spout installation yet, so you need to get it from the file download instead of the installer.
    I will update the post above.

    I was using Winamp 5.63, so I installed 5.666 and it still works OK. Somebody has reported that Ctrl-Z causes a jump to the first song in the playlist, but I have not been able to reproduce that. So if you see it or not, please let me know.

    When the visualizer starts, Spout output is automatically started. You only need to use Ctrl-Z if you want to stop it and re-start it for any reason, such as saving computer resources when you don’t want Spout output. So you probably won’t need to use it normally.

    #978

    wildcat
    Participant

    Thanks for your reply. I downloaded the Spout2_v2.001_files.zip but it does not contain the Milkdrop plugin.

    I managed to download both files from the original location by right clicking on the links to view RAW and saving the raw files directly, originally the browser had only downloaded the webpage and given it the file’s name.

    #979

    leadedge
    Keymaster

    It goes from bad to worse.

    Here is a DropBox link until I can sort this out :

    https://www.dropbox.com/sh/wgi26af3qrp0rhn/AADAuS-3Xhpvu4rqDPVuxKNBa?dl=0

    If all goes well I will put it in the installation but it hasn’t had enough testing yet.

    #980

    zboyz2014
    Participant

    Dear Leadedge,

    Thank you for your efforts to put it on.
    I’ve been looking for this one for years.

    You said the:

    vis_milk2.dll should be 828kb but I have it 628kb here

    Also I am using windows 8.1 x64 and not running.

    Where the spoutsender2.exe must be? Inside winamp root? I am on version 5.63 (x86)

    And spoutpanel.exe(196kb) where it goes? Resolume root?

    I am planning to run it with Resolume Arena (4.1.8 and 4.1.11 versions here – both 32 bit)

    vis_milk2.dll (628kb) is loading on winamp (5.63) but it does not open spoutsender2

    Resolume is displaying no image on spoutreceiver2.exe

    When I run spoutsender.exe demo (32 bit) it shows up on spoutpanel2 and also inside Resolume both versions (directX 11 640×360 BGRA)

    I am using Geforce 344.11 on GTX850 4 mb on my asus laptop

    Please let me know what you would like to see tested from here.

    Feel free to use my feedback since I have some experience (not into programming)

    What do you reckon next? Should I run windows 32 bit?

    How can I change the resolution out of sender to something like 1920 x 1080?

    Thank you!!!

    Please keep going on it!!!

    #981

    wildcat
    Participant

    It is working fine for me now. I believe you may have put in a typo when you stated the file size as I have 628KB like zboy2014.

    zboy2014 I would suggest using the spoutcam inside Resolume as I did not have as much luck with the spout receiver plugin as spoutcam.

    #982

    leadedge
    Keymaster

    Yes a typo, 628k – this is only to check anyway.

    zboy2014 – for Winamp you only need vis_milk2.dll and glut32.dll. Copy them as instructed in the readme file.

    Then when you run Winamp, if the Visualizer works at all then it will be OK. Try Ctrl-Z. It should toggle Spout output and you should see this indicated in the same way as a song title.

    Winamp is a Spout sender and so is picked up by a receiver. Start the Demo receiver. It should pick up the Winamp output.

    SpoutSender2.dll and SpoutReceiver2.dll are Freeframe plugins and go in the pulgins\vfx folder for Resolume. SpoutPanel.exe goes in the same folder as Arena.exe.

    In Arena look into “Sources” to find SpoutReceiver2, drag it to an empty cell and click on it. It should pick up Winamp straight away. If not, click on “Select Sender” to select “WinampSpoutSender”.

    It should all work on a 64-bit machine because both Winamp and Resolume are 32-bit programs.

    #983

    zboyz2014
    Participant

    Dear leadedge,

    Thanks for feedback man.

    Yes winamp is working and when I press ctrl-Z it shows the message that the sender is “enabled” but still got no image on demo receiver (both versions DX9 and DX11) and resolume Spoutreceiver2.

    Any sugestion from here?

    Note that I am using winamp 5.63 32 bit (original release)

    May I use the open source version of Mikdrop (how?) or just vis_milk2.dl is enough for that.

    Please let me know.

    Thank you again…

    #984

    zboyz2014
    Participant

    Also Spoutreceiver (demo DX9 and DX11) shows the message “textureshare receiver no sender detected”

    I hope it helps…

    #985

    zboyz2014
    Participant

    maybe permissions to access spoutpanel inside resolume?

    how to enable it under windows 8.1?

    #986

    leadedge
    Keymaster

    Not sure of what the problem is yet, but would like to find out.

    I have used Winamp 5.63 and 5.666 and they both work OK.

    Wildcat has it working, so it could be something simple.

    One thing – when you hit Ctrl-Z the output is disabled, so you have to hit it again to get the output enabled before anything will be received by a receiver. “WinampSpoutSender” should show up in the list. Or start WInamp and don’t use Ctrl-Z at all and it should be sending straight away.

    Make sure you are using the latest Spout update 2.001. The version of “SpoutPanel.exe” in there is different to the previous one.

    Can you confirm that the demo sender is received by the demo receiver. Is there any combination that does not work? It could be a DirectX9/11 issue or 64bit problem. I will have a look at both.

    The Open source vis_milk2.dll is installed with Winamp. I have recompiled from the source and it is the same apart from Spout output. The modified source files are on the Spout GitHub.

    #987

    zboyz2014
    Participant

    Thanks,

    Yes I know about ctrl_z on and off (saw that)

    Its strange because spoutsender2dx11 (demo) sends the signal straight way to resolume and I can see the demo cube running straight

    But it does not show any from winamp.

    Even spoutpanel2 can show source from demo but not from winamp

    I have two versions of spoutpanel2 one 10/21/2014 and other 10/27/2014

    ON my windows syatem32 and syswow dirs I have glu32.dll and glut32.dll (on both)

    Yes I got spout 2.01 installed

    It seems that there is no issue related to spoutreceiver2 on resolume since it accepts the spoutsender2 demo signal.

    It looks like more like something from winamp that is not directioning it to the spoutpanel2 or spoutreceiver2…

    Wildcat is using a 64bit machine as me? what is the TYPO means? a mistake on typing you mean? so the 628kb version is ok?

Viewing 15 posts - 1 through 15 (of 81 total)

You must be logged in to reply to this topic.